In developing RebelGive, we try to reach the majority of the population who uses the internet. We check to see what the most popular browsers are, and cater RebelGive (both the GivingFlow trigger and access to the Control Center) to those browsers. By popular, we don’t simply mean the most widely used; we mean we cater to browsers that 0.2% and higher of the global population use (excluding Internet Explorer for various reasons, of which will be listed below). Popularity also factors in how old those browsers are (i.e. the older the browser version, the less used it is), so if you're using an older version of an iOS (Apple) or other operating system / internet browser and you can't see the RebelGive trigger load (or you're unable to log into your RebelGive Control Center), that might be why.

Below is an image of all current internet browsers that RebelGive will successfully load and function in. Note the percentages beside each browser denotes the global population using those browsers.

Why Not Internet Explorer?

Back in January 2016 (more than 3 years ago), Microsoft stopped updating Internet Explorer (IE). They have since not updated it or provided any security improvements to that platform. Because of this, we didn't develop RebelGive's platform to operate on IE and we don't have any plans in the future to do so.

Edge is Microsoft's newer internet browser to replace IE. We highly recommend suggesting to anyone who still uses IE to switch to Edge. Not only will they be provided with more security when browsing the internet, but the browser itself is much better, both in stability and browsing speed.

Which Mobile Apple Products Can RebelGive Load On?

Based on current trends, RebelGive will function and load on any mobile Apple products operating on iOS 10.3 or newer. 

iPads

The following list are iPads that will not load RebelGive:

  • iPad (1st Gen)
  • iPad (2nd Gen)
  • iPad (3rd Gen)
  • iPad Mini (1st Gen)

iPad (4th Gen) can operate iOS 10.3.3; however, this will most likely be the last version of iOS it will support, meaning RebelGive may eventually stop servicing iOS Safari 10.3. If you're using an iPad for a kiosk in your church, we recommend using nothing older than the iPad Air (1st Gen) or the iPad Mini (2nd Gen).

iPhones

The following list are iPhones that will not load RebelGive:

  • iPhone
  • iPhone 3G/S
  • iPhone 4/4S

Just like with the iPad (4th Gen), the iPhone 5/C can operate iOS 10.3.3; however, this will most likely be the last version of iOS it will support, meaning RebelGive may eventually stop servicing iOS Safari 10.3.

Did this answer your question?